解决Intellij idea Error:java: 无效的源发行版: 1.8

释放双眼,带上耳机,听听看~!

新建项目编译出现错误如下:

原因在于模块的target bytecode version和实际的编译器版本不一致所导致的错误。
不管三七二十一,把所有jdk版本统统改成一样的,首先按下快捷键ctrl+shift+alt+s:

把项目sdk改好后再来模块的sdk也改下:

最后按下快捷键 ctrl+shift+s 修改Java Compiler配置,把byte code version和sdk版本统一,别管谁高谁低,保证一样了就没问题:

当然如果你是maven项目的话,可能还需要改下pom.xml文件的jdk版本配置:

<build>  
    <plugins>  
        <plugin>  
            <groupId>org.apache.maven.plugins</groupId>  
            <artifactId>maven-compiler-plugin</artifactId>  
            <configuration>  
                <source>1.7</source>  
                <target>1.7</target>  
            </configuration>  
        </plugin>  
    </plugins>  
</build>  

https://blog.csdn.net/c15158032319/article/details/79577458

给TA买糖
共{{data.count}}人
人已赞赏
代码

idea中pom.xml文件横线解决办法

2021-6-30 18:25:17

代码

jdk-16 没有jre文件目录解决

2021-7-16 14:06:49

0 条回复 A文章作者 M管理员
    暂无讨论,说说你的看法吧
个人中心
购物车
优惠劵
今日签到
有新私信 私信列表
搜索